在線檢測未來函數

通達信道破天機指標公式

來源:Internet,編輯:股旁網,2010-05-24

參數: n 1 999 13

VAR2:=MA(CLOSE,5);
VAR3:=MA(CLOSE,10);
VAR4:=MA(CLOSE,20);
VAR5:=MA(CLOSE,30);
VAR6:=((((VAR2 + VAR3) + VAR4) + VAR5) / 4);
VAR7:=(((VAR6 - REF(VAR6,N)) / REF(VAR6,N)) * 100);
VAR9:=EMA(VAR7,5);
反轉:STICKLINE(VAR9>1*REF(VAR9, 1), VAR7, 0, 5, 0), COLOREE00EE;
持股:STICKLINE(VAR7>1*REF(VAR7, 1), VAR7, VAR9, 5, 0), COLORRED;
持幣:STICKLINE(VAR7<1*REF(VAR7, 1), VAR7, VAR9, 5, 1), COLORGREEN;
洗盤:STICKLINE(VAR7<1*REF(VAR7, 1) AND VAR9>1*REF(VAR9, 1), VAR7, VAR9, 10, 0),
COLOR00EEFF;
STICKLINE((((VAR7 < REF(VAR7,1)) AND (VAR9 > (1 * REF(VAR9,1)))) AND (VAR7 >
0)),0,VAR9,5,0),COLORFF00FF;
生死線:0,COLOR7766CC;
VAR10:=(((CLOSE - MA(CLOSE,58)) / MA(CLOSE,58)) * 100);
VAR11:=((((VAR10 > (1 * REF(VAR10,1))) AND (VAR10 < (0 - 26))) AND (VAR10 > (0 - 40))) * 1.5);
VAR12:=((VOL / CAPITAL) * 100);
VAR13:=LLVBARS(LOW,50);
VAR14:=SUM(VOL,VAR13);
VAR15:=HHVBARS(HIGH,50);
VAR16:=SUM(VOL,VAR15);
VAR17:=(((CLOSE - REF(OPEN,VAR15)) / REF(OPEN,VAR15)) * 100);
VAR18:=((VAR16 / CAPITAL) * 100);
VAR19:=(((CLOSE - REF(OPEN,VAR13)) / REF(OPEN,VAR13)) * 100);
VAR20:=((VAR14 / CAPITAL) * 100);
VAR21:=MA(CLOSE,3);
VAR22:=(REF(CLOSE,2) * 0.865);
VAR23:=(REF(CLOSE,13) * 0.772);
VAR24:=MIN(VAR22,VAR23);
VAR25:=MA(CLOSE,13);
大底:(IF((((((CLOSE - VAR24) / CLOSE) < 0.03) AND (VAR17 < (0 - 35))) AND ((SUM(VAR12,7) / 5) <
1.8)),1,0) * 10),LINETHICK2,COLORFFFF00;
VAR26:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);
VAR27:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);
VAR28:=EMA(VAR27,9);
VAR29:=(2 * (VAR27 - VAR28));
STICKLINE(((VAR27 < (0 - 50)) AND (VAR26 > 7)),0,(0 - 10),5,0),COLORFFFF66;
DRAWTEXT(((VAR27 < (0 - 50)) AND (VAR26 > 7)),(0 - 10),'單邊追漲');
DRAWTEXT(大底,8,'大底-成功率95%'),COLORFFFFFF;
DRAWICON((CROSS(VAR9,VAR7) AND (VAR7 > 0)),VAR9,5);
DRAWTEXT((CROSS(VAR9,VAR7) AND (VAR7 > 0)),VAR9,' 逃頂'),COLORWHITE;
KS13:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * (0 - 100));
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
FASTK:=SMA(RSV,3,1);
D:=SMA(FASTK,3,1);
VA1:=SMA(D,5,1);
VA2:=(((CLOSE / MA(CLOSE,40)) * 100) < 76);
VA3:=(((CLOSE / MA(CLOSE,60)) * 100) < 74);
VA4:=(HIGH > (LOW * 1.051));
FNZH:=(VA4 AND (COUNT(VA4,5) > 1));
LC:=((((FNZH AND (VA2 OR VA3)) AND (REF(KS13,1) >= 10)) AND ((REF(KS13,1) / KS13) >= 1.13))
AND ((CLOSE / REF(CLOSE,1)) >= 1.02));
DRAWICON(LC,5,12);
DRAWTEXT(LC,15,'反彈'),COLOR0000FF;
RSI:=REF(CLOSE,1);
VAR58:=((SMA(MAX((CLOSE - RSI),0),6,1) / SMA(ABS((CLOSE - RSI)),6,1)) * 100);
DRAWICON(((REF(VAR58,1) > 85) AND CROSS(84,VAR58)),VAR7,5);
VARL:=TROUGHBARS(3,15,1)<10;
VARK:=PEAKBARS(3,15,1)<10;
VARJ:=IF(VARL=1,10,0);
VARH:=IF(VARK=1,10,0);
底部S:=IF(VARJ=10,4,0);
多頭能量:0,COLORWHITE,LINETHICK0;
神仙腳買入:IF(底部S=4 AND REF(底部S,1)=4 AND REF(底部S,2)
=0,8,0),COLORFFFF00,LINETHICK4;
DRAWTEXT(底部S=4 AND REF(底部S,1)=4 AND REF(底部S,2)=0,8.5,'神仙腳買入')
COLORYELLOW;
買入延遲線:底部S,LINETHICK3,COLOR00CCFF;
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)
*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
持幣區域:VAR1,COLORFEDCBA,LINETHICK4;
持股區域:IF(VAR1>0,VAR1,0),COLOR00BBFF,LINETHICK4;
短頂:STICKLINE(VAR1>9 AND FILTER(VAR1< REF(VAR1,1),5),VAR1+2,0,3,0),COLORGREEN;
大頂:STICKLINE(VAR1>20 AND FILTER(VAR1< REF(VAR1,1),5),VAR1+5,0,7,0),COLOR00FF00;
VAR2D:=HHV(VAR1>20,10);
危險: STICKLINE(VAR2D AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD
(CLOSE,20)),VAR1+10,0,4,0);
注意止損:STICKLINE(VAR2D AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA
(CLOSE,5),MA(CLOSE,2)),VAR1+6,0,3,0);
短底:STICKLINE(VAR1<-9 AND VAR1> REF(VAR1,1),VAR1-2,0,3,0),COLORRED;
大底D:STICKLINE(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-
5,0,7,0),COLORYELLOW;
買入準備:VAR1<-9 AND VAR1> REF(VAR1,1) ,LINETHICK3,COLORWHITE;
最佳買入:ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG
(3,10),2),COLORRED,LINETHICK2;
P1:=BARSSINCE(最佳買入=1);
{P1:=1011022;}
{21}
P:=21;
MM1:=IF(DATE>P1,1,0);
MM11:=SUM(MM1,0);
MM:=MM11-1;
MM2:=IF(MM>0,1,0);
MMA1:=MM-INTPART((MM)/P)*P;
MMB:=P-MMA1;
MMB1:=IF(MMB=P,0,MMB);
STICKLINE( MMA1=0,0,20,1 ,0 ),LINETHICK2,COLORRED;
AAQ:=DATE;
AA1Q:=IF(AAQ>=P1,1,0);
AA2Q:=SUM(AA1Q,0)-2;
MMQ:=AA2Q;
MM2Q:=IF(MMQ>0,1,0);
MMA1Q:=MMQ-INTPART((MMQ)/P)*P;
MMBQ:=P-MMA1Q;
剩余21:MMB1,NODRAW;
{14}
PMM:=14;
MMMM1:=IF(DATE>P1,1,0);
MMMM11:=SUM(MMMM1,0);
MMMM:=MMMM11-1;
MMMM2:=IF(MMMM>0,1,0);
MMMMA1:=MMMM-INTPART((MMMM)/PMM)*PMM;
MMMMB:=PMM-MMMMA1;
MMMMB1:=IF(MMMMB=PMM,0,MMMMB);
STICKLINE( MMMMA1=0,0,10,1 ,0 ),LINETHICK2,COLORGREEN;
AAQMM:=DATE;
AA1QMM:=IF(AAQMM>=P1,1,0);
AA2QMM:=SUM(AA1QMM,0)-2;
MMMMQMM:=AA2QMM;
MMMM2QMM:=IF(MMMMQMM>0,1,0);
MMMMA1QMM:=MMMMQMM-INTPART((MMMMQMM)/PMM)*PMM;
MMMMBQMM:=PMM-MMMMA1QMM;
剩余14:MMMMB1,NODRAW;
{7}
PM:=7;
MMM1:=IF(DATE>P1,1,0);
MMM11:=SUM(MMM1,0);
MMM:=MMM11-1;
MMM2:=IF(MMM>0,1,0);
MMMA1:=MMM-INTPART((MMM)/PM)*PM;
MMMB:=PM-MMMA1;
MMMB1:=IF(MMMB=PM,0,MMMB);
STICKLINE( MMMA1=0,0,5,1 ,0 ),LINETHICK2,COLORWHITE;
AAQM:=DATE;
AA1QM:=IF(AAQM>=P1,1,0);
AA2QM:=SUM(AA1QM,0)-2;
MMMQM:=AA2QM;
MMM2QM:=IF(MMMQM>0,1,0);
MMMA1QM:=MMMQM-INTPART((MMMQM)/PM)*PM;
MMMBQM:=PM-MMMA1QM;
剩余7:MMMB1,NODRAW;
周期1:MMBQ;
周期2:MMMMBQMM;
周期3:MMMBQM;
負1:-MMBQ;
負2:-MMMMBQMM;
負3:-MMMBQM;
變化1:剩余21-剩余14;
變化2:剩余14-剩余7;
變化3:剩余21-剩余7;
變化4:-(剩余21-剩余14);
變化5:-(剩余14-剩余7);
變化6:-(剩余21-剩余7);

 

相關文章

3d彩票软件excel