在線檢測未來函數

做出現虎到時候選股預警

來源:Internet,編輯:股旁網,2012-09-22

編寫要求:

VAR2N:=1; V1:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20); V2:=(2 * ABS(V1)); V3:=(100 - ((100 - (3 * SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1)))); V4:=(100 - ((100 - (3 * SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1)))); V5:=(((HIGH + LOW) + CLOSE) / 3); V6:=((V5 - MA(V5,10)) / (0.015 * AVEDEV(V5,10))); V7:=((V5 - MA(V5,30)) / (0.015 * AVEDEV(V5,30))); V8:=IF(((((V6 >= 150) AND (V6 < 200)) AND (V7 >= 150)) AND (V7 < 200)),10,0); V9:=(IF(((((V6 <= (0 - 150)) AND (V6 > (0 - 200))) AND (V7 <= (0 - 150))) AND (V7 > (0 - 200))),(0 - 10),V8) * VAR2N); VA:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100); VB:=(100 - ABS(VA)); VC:=((3 * SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1))); VD:=((3 * SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1))); VE:=(REF(LOW,1) * 0.9); VF:=(LOW * 0.9); V10:=(((VF * VOL) + (VE * (CAPITAL - VOL))) / CAPITAL); V11:=EMA(V10,30); V12:=(V11 - CLOSE); V13:=REF(CLOSE,1); V14:=((SMA(MAX((CLOSE - V13),0),7,1) / SMA(ABS((CLOSE - V13)),7,1)) * 100); V15:=((SMA(MAX((CLOSE - V13),0),13,1) / SMA(ABS((CLOSE - V13)),13,1)) * 100); V16:=BARSCOUNT(CLOSE); V17:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 100); V18:=(((((0 - 100) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 50) * 2); V19:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100); V1A:=((SMA(V19,4,1) - 50) * 2); V1B:=SMA(V1A,3,1); V1C:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100); V1D:=SMA(V1C,4,1); V1E:=SMA(V1D,3,1); V1F:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100); V20:=(IF((((((((((V17 <= 25) AND (V18 < (0 - 95))) AND (V1F > 20)) AND (V1B < (0 - 30))) AND (V1E < 30)) AND (V12 >= (0 - 0.25))) AND (V14 < 22)) AND (V15 < 28)) AND (V16 > 50)),80,0) * VAR2N); 空方:(0 - (IF((V1 < 0),V2,0) * VAR2N)),LINESTICK C1:=HHV(C0,55); C2:=LLV(C0,55); C3:=(C1 - C2); C4:=(EMA(((C0 - C2) / C3),2) * 100); A10:=(A4 - 50); A20:=(B4 - 50); A30:=(C4 - 50); DRAWICON(CROSS(A1,0),0,4); RSV2:=(((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30))) * 100); K2:=SMA(RSV2,3,1); D2:=SMA(K2,3,1); J2:=((3 * K2) - (2 * D2)); 動力線:(EMA(J2,6) * VAR2N),COLOR00FFFF; VAR2W:=EMA(CLOSE,5); RSI1W:=((SMA(MAX((CLOSE - VAR2W),0),6,1) / SMA(ABS((CLOSE - VAR2W)),6,1)) * 100); RSI2W:=((SMA(MAX((CLOSE - VAR2W),0),3,1) / SMA(ABS((CLOSE - VAR2W)),3,1)) * 100); VAR1F:="KDJ.D"(18,5,6); 虎:IF(((((((((動力線 < 15.5) AND (空方 < (0 - 30))) AND (VAR1F < 35)) AND (RSI1W < 10)) AND (RSI2W < 6.5)) AND (A10 < (0 - 47))) AND (A20 < (0 - 47))) AND (A30 < (0 - 48.5))),50,0); 牛:(IF(((空方 < (0 - 38)) AND (虎 > 0)),70,0) * VAR2N); VAR2:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273)); VAR21:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100); VAR22:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125)); 獲利線:=(VAR2 AND VAR22); LC:=EMA((WINNER(CLOSE) * 100),3); VAR2Q:=EMA(CLOSE,3); 神奇線:=((SMA(MAX((CLOSE - VAR2Q),0),6,1) / SMA(ABS((CLOSE - VAR2Q)),6,1)) * 100); 買點一:=MA(神奇線,10); 牛A:(IF((VAR22 AND (神奇線 < 3)),(0 - 40),0) * VAR2N),LINETHICK2,COLOR3399FF; 牛B:(IF((VAR22 AND (買點一 < 9)),(0 - 38),0) * VAR2N),LINETHICK2,COLOR3399FF; 劍:(FILTER(((神奇線 < 6) AND 獲利線),35) * 1),STICK,LINETHICK2,COLORFF0000; DRAWICON((劍 > 0),1,1); 牛3:(IF((((LC < 1.5) AND (買點一 < 21)) AND (神奇線 < 5.5)),80,0) * VAR2N),LINETHICK2,COLOR3399FF; VAR1N:=1050431; VAR2N1:=IF((DATE<=VAR1N),1,0); 穩賺:=(MA(CLOSE,80) - (MA(CLOSE,13) / 3)); 買點二:=MA(((CLOSE - 穩賺) / 穩賺),1); XA:=IF((CROSS(買點二,0) AND ((LOW / REF(HIGH,1)) < 1.012)),0.5,0); XB:=IF((((COUNT((買點二 > REF(買點二,1)),3) = 3) AND (COUNT((買點二 < 0),10) = 10)) AND (REF(買點二,3) = LLV(買點二,10))),0.5,0); VAR82:=IF((((((REF(買點二,2) = LLV(買點二,20)) AND (REF(買點二,2) < 0.071)) AND (REF(買點二,2) < REF(買點二,1))) AND NOT(((REF(LOW,1) > REF(HIGH,2)) AND (LOW > REF(HIGH,1))))) AND (CLOSE > REF(CLOSE,1))),0.5,0); VAR83:=(EMA(買點二,12) * 0.7); VAR84:=EMA(買點二,3); 底部將成:(IF((LLV((VAR84 - VAR83),5) > 0),0,(0 - 40)) * VAR2N1),COLORFFCC66;

股旁網解答:

 V1:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20);

V2:=(2 * ABS(V1));
空方:=(0 - (IF((V1 < 0),V2,0)));
C0:=(((HIGH + LOW) + CLOSE) / 3);
A1:=HHV(C0,14);
A2:=LLV(C0,14);
A3:=(A1 - A2);
A4:=(EMA(((C0 - A2) / A3),2) * 100);
B1:=HHV(C0,30);
B2:=LLV(C0,30);
B3:=(B1 - B2);
B4:=(EMA(((C0 - B2) / B3),2) * 100);
C1:=HHV(C0,55);
C2:=LLV(C0,55);
C3:=(C1 - C2);
C4:=(EMA(((C0 - C2) / C3),2) * 100);
A10:=(A4 - 50);
A20:=(B4 - 50);
A30:=(C4 - 50);
 
RSV2:=(((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30))) * 100);
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=((3 * K2) - (2 * D2));
動力線:=(EMA(J2,6) );
VAR2W:=EMA(CLOSE,5);
RSI1W:=((SMA(MAX((CLOSE - VAR2W),0),6,1) / SMA(ABS((CLOSE - VAR2W)),6,1)) * 100);
RSI2W:=((SMA(MAX((CLOSE - VAR2W),0),3,1) / SMA(ABS((CLOSE - VAR2W)),3,1)) * 100);
VAR1F:="KDJ.D"(18,5,6);
虎:((((((((動力線 < 15.5) AND (空方 < (0 - 30))) AND (VAR1F < 35)) AND (RSI1W < 10)) AND (RSI2W < 6.5)) AND (A10 < (0 - 47))) AND (A20 < (0 - 47))) AND (A30 < (0 - 48.5)));
 

相關文章

3d彩票软件excel