在線檢測未來函數

通達信股票買賣主圖指標公式

來源:Internet,編輯:股旁網,2019-06-11

AA05:MA(C,30);
MA1:MA(CLOSE,30);
MA2:MA(CLOSE,40);
MA3:MA(CLOSE,50);
MA4:MA(CLOSE,60);
MA5:MA(CLOSE,70);
MA6:MA(CLOSE,80);
MA7:MA(CLOSE,90);
MA8:MA(CLOSE,100);
MA9:MA(CLOSE,110);
MA10:MA(CLOSE,120);
五日乖離率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;
AA10:MA(C,30);AA20:=MA(C,30);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:MA(C,30);
DRAWTEXT_FIX(C>0,0,0.05,0,'( 8 )'),COLORMAGENTA;
三拾日乖離率:=(C-AA30)/AA30*100,LINETHICK0;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
強勢狙擊:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加倉:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖離率>REF(三拾日乖離率,1) AND AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清倉:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖離率<REF(三拾日乖離率,1) AND AA10<REF(AA10,1),10);
DRAWTEXT(加倉 ,LOW*0.98,'加倉'),COLORRED;
JC:=CROSS(0,五日乖離率) AND 三拾日乖離率<REF(三拾日乖離率,1) AND AA10>REF(AA10,1) ;
減倉:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖離率,0),3)>=1 AND 三拾日乖離率>REF(三拾日乖離率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
買入:=FILTER(MR,10);
DRAWTEXT(減倉,HIGH*1.02,'減倉'),COLORCYAN;
DRAWTEXT(買入,LOW*0.98,'買入'),COLORYELLOW;
DRAWTEXT(清倉 ,HIGH*1.02,'清倉'),COLORGREEN;
DRAWTEXT(強勢狙擊,LOW*0.98,'狙擊'),COLORYELLOW;
AAA:=CONST(HHV(H*0.5,90));
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))+ IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T1:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T2:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T3:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)),1,0));
T4:=CONST(IF(C<200 AND ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)),1,0));
T5:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T6:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T7:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T8:=CONST(IF(C<200 AND ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T9:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T10:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T11:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T12:=CONST(IF(C<200 AND ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T13:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T14:=CONST(IF( C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)),1,0));
T15:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)),1,0));
T16:=CONST(IF(C<200 AND ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)),1,0));
T17:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 < V2)),1,0));
T20:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 < V2)),1,0));
T22:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)),1,0));
T24:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)),1,0));
T25:=CONST(IF(C>200 AND (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)),1,0));
{漲停柱紅漲停蘭跌停}
C2:=REF(C,1);
漲停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(漲停,OPEN,CLOSE,2,0),COLOR0000FF;
STICKLINE(漲停,H,L,0,0),COLOR0000FF;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
DRAWTEXT(T1=1 AND CURRBARSCOUNT=70,CLOSE,'量能理想,明顯走強,中線參與,倉位在2/3左右。'),COLORFF00FF ;
DRAWTEXT(T2=1 AND CURRBARSCOUNT=70,CLOSE,'走勢趨強,還顯不足,短線進場,倉位在1/2左右。'),COLORFFFFFF ;
DRAWTEXT(T3=1 AND CURRBARSCOUNT=70,CLOSE,'量價良好,沒有明顯走強,短線進場,倉位1/2左右。'),COLORFFFFFF ;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=70,CLOSE,'形態尚可,量能不足,未完全走強,短線參與,倉位1/3左右。'),COLORFFFFFF ;
DRAWTEXT(T5=1 AND CURRBARSCOUNT=70,CLOSE,'形態變壞,重倉者減持大半,清倉者觀望。'),COLORFFFFFF ;
DRAWTEXT(T6=1 AND CURRBARSCOUNT=70,CLOSE,'隨大盤一起下跌,明顯縮量走勢,考慮到風險,減持或清倉。'),COLORFFFFFF ;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=70,CLOSE,'該股放量下跌,走勢明顯偏弱,離場觀望。'),COLORFFFFFF ;
DRAWTEXT(T8=1 AND CURRBARSCOUNT=70,CLOSE,'該股縮量下跌,走勢偏弱,離場觀望。'),COLORFF00FF ;
DRAWTEXT(T9=1 AND CURRBARSCOUNT=70,CLOSE,'該股形態良好,強勢明顯,量能充足,可以繼續持有。'),COLORFFFFFF ;
DRAWTEXT(T10=1 AND CURRBARSCOUNT=70,CLOSE,'上行趨勢不變,強勢依然,量能開始轉弱,注意風險。'),COLORFFFFFF ;
DRAWTEXT(T11=1 AND CURRBARSCOUNT=70,CLOSE,'該股仍然具備上漲潛力,但股性偏弱,可考慮減倉。'),COLORFFFFFF ;
DRAWTEXT(T12=1 AND CURRBARSCOUNT=70,CLOSE,'該股走勢趨弱,量能不足,減持大部分籌碼。'),COLORFFFFFF ;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=70,CLOSE,'該股形態不佳,注意成交量的變化,目前不適合參與。'),COLORFFFFFF ;
DRAWTEXT(T14=1 AND CURRBARSCOUNT=70,CLOSE,'趨勢不明,股價偏弱,注意量能變化,目前不宜參與。'),COLORFFFFFF ;
DRAWTEXT(T15=1 AND CURRBARSCOUNT=70,CLOSE,'有走強跡象,但量能不足,趨勢不明,不適合操作。'),COLORFFFFFF ;
DRAWTEXT(T16=1 AND CURRBARSCOUNT=70,CLOSE,'該股走勢太弱,沒有參與價值。'),COLORFF00FF ;
DRAWTEXT(T17=1 AND CURRBARSCOUNT=70,CLOSE,'大盤理想,有明顯走強跡象,中線參與,倉位在2/3左右。'),COLORFFFFFF ;
DRAWTEXT(T18=1 AND CURRBARSCOUNT=70,CLOSE,'如前期經過一輪下跌,最佳買點,前期有過一段漲幅需謹慎。'),COLORFFFFFF ;
DRAWTEXT(T19=1 AND CURRBARSCOUNT=120,CLOSE,'考慮短線進場,倉位在1/2左右,一旦量能放大,加倉買入。'),COLORFFFFFF ;
DRAWTEXT(T20=1 AND CURRBARSCOUNT=70,CLOSE,'大盤形態走壞,重倉者可以減去大部分倉位。'),COLORFF0000 ;
DRAWTEXT(T21=1 AND CURRBARSCOUNT=70,CLOSE,'大盤縮量調整,注意風險,短線清倉觀望。'),COLORFF0000 ;
DRAWTEXT(T22=1 AND CURRBARSCOUNT=70,CLOSE,'大盤走勢良好,量能理想,可以繼續持有強勢股。'),COLORFF0000 ;
DRAWTEXT(T23=1 AND CURRBARSCOUNT=70,CLOSE,'大盤形態良好,但量能稍顯不足,隨時準備減倉。'),COLORFF0000 ;
DRAWTEXT(T24=1 AND CURRBARSCOUNT=70,CLOSE,'大盤趨勢不明,注意成交量變化,目前不適宜進場。'),COLORFF0000 ;
DRAWTEXT(T25=1 AND CURRBARSCOUNT=70,CLOSE,'大盤趨勢向下,量能萎縮,不適合進場。'),COLORFF0000 ;
壓力:MA(REF(HHV(C,30),1),2),COLORBLUE,DOTLINE,LINETHICK2;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.08,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.16,0,0,GNBLOCK),COLORYELLOW;
BB:REF(V,BARSLAST(TIME>=92500 AND TIME<=93000));
DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,BB),COLORYELLOW;

通達信股票買賣主圖指標公式

 

相關文章

3d彩票软件excel