在線檢測未來函數

通達信資金流+成交量指標公式

來源:Internet,編輯:股旁網,2019-06-11

DRAWGBK(C>0,RGB(0,9,2),RGB(0,95,0),0,'0',0);
量:V,VOLSTICK;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))); XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN)
,(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
進攻流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
GJJ:=EMA(進攻流量,8);
LLJX:=EMA(進攻流量,3);
動態天量:=CONST(IF(V=HHV(V,20),V,REF(V,BARSLAST(V=HHV(V,20))))),COLOR00FF00,POINTDOT;
STICKLINE(((HSL * 0.4) >= 0),動態天量+((HSL * 0.4) +LLJX)*20,動態天量,3,0),COLORYELLOW;
STICKLINE(((HSL * 0.4) < 0),動態天量+((HSL * 0.4) +LLJX)*20,動態天量,3,0),COLOR00FF00;
資金流入:=IF((HSL*0.4+LLJX)> 0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;
資金流出:=IF((HSL*0.4+LLJX)< 0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;
資金收支:=(HSL*0.4+LLJX),LINETHICK0;{股旁網 www.vwdidt.tw}
萬元:=AMOUNT/10000{0000},VOLSTICK,COLORFF00FF;
資金凈收支:IF((HSL*0.4+LLJX)> 0,資金流入,資金流出),COLORWHITE,POINTDOT;
收支比例%:IF((HSL*0.4+LLJX)> 0,資金流入/萬元*100,資金流出/萬元*100),COLORYELLOW;
連紅天1:=BARSLASTCOUNT(資金凈收支>0),,COLORA20FFD,NODRAW;
連紅天2:=IF(連紅天1=0,REF(連紅天1,1),連紅天1),,COLORA20FFD,NODRAW;
連紅天3:=IF(連紅天2=0,REF(連紅天1,2),連紅天2),,COLORA20FFD,NODRAW;
連紅天4:=IF(連紅天3=0,REF(連紅天1,3),連紅天3),,COLORA20FFD,NODRAW;
近期連紅天:IF(連紅天4=0,REF(連紅天1,4),連紅天4),,COLORYELLOW,NODRAW;
三日資金:SUM(資金收支,3),COLORWHITE,NODRAW;
五日資金:SUM(資金收支,5),COLORFF00FF,NODRAW;
十日資金:SUM(資金收支,10),COLOR0000FF,NODRAW;
資金流量:=LLJX,LINETHICK0,COLOR0000FF;
STICKLINE((資金流量 > 0),動態天量+資金流量*20,動態天量,3,0),COLOR0000FF;
STICKLINE((資金流量 < 0),動態天量+資金流量*20,動態天量,3,0),COLOR008000;
{量能飽和度}
N1:=10,100,34;
N2:=N1*1.05;
N3:=N1+3;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能飽和度:IF(SAT> 1,1,SAT)*100,COLORLIBLUE,NODRAW;
中點:=REFDATE(HHV(V,100)/2,DATE);{量能飽和的變色切換}
STICKLINE(CURRBARSCOUNT=N1,中點*1.9,中點*1.5,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=N1,中點*1.88,中點*1.52,量能飽和度,0),COLOR0033FF;
STICKLINE(CURRBARSCOUNT=N1,中點*1.82,中點*1.58,量能飽和度,0),COLOR0077FF;
STICKLINE(CURRBARSCOUNT=N1,中點*1.76,中點*1.64,量能飽和度,0),COLOR0099FF;
STICKLINE(CURRBARSCOUNT=N1,中點*1.7,中點*1.7,量能飽和度,0),COLOR00DDFF;
DRAWTEXT(CURRBARSCOUNT=N3,中點*1.70,'量能飽和度'),COLOR000000;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
買盤:IF(CLOSE> OPEN,VAR1*(HIGH-LOW),IF(CLOSE< OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
賣盤:-IF(CLOSE> OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLORCYAN,POINTDOT;
成交量比%:買盤/VOL*100,COLORWHITE,NODRAW;
萬手:VOL/10000,LINETHICK0;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
預測:AA/10000;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主動買:=IF(CLOSE> OPEN,BB*(HIGH-LOW),IF(CLOSE< OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主買:主動買/10000,COLORRED;
主動賣:=IF(CLOSE> OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE< OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主賣:-主動賣/10000,COLORGREEN;
差額:(主動買+主動賣)/10000;
STICKLINE(CLOSE= REF(CLOSE,1),0,VOL,3.5,0),COLORWHITE;
STICKLINE(CLOSE> REF(CLOSE,1),0,VOL,3.5,0),COLORRED;
STICKLINE(CLOSE< REF(CLOSE,1),0,VOL,3.5,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLOR00FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR007777 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR009999 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00BBBB ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR00DDEE ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.2 , 0 ) , COLORFFFFFF ;
STICKLINE(主動買>= 0,VOL,-主動賣,3.2,0),COLOR000033;
STICKLINE(主動買>= 0,VOL,-主動賣,2.7,0),COLOR000066;
STICKLINE(主動買>= 0,VOL,-主動賣,2.1,0),COLOR000099;
STICKLINE(主動買>= 0,VOL,-主動賣,1.5,0),COLOR0000CC;
STICKLINE(主動買>= 0,VOL,-主動賣,0.9,0),COLOR0000FF;
STICKLINE(主動買>= 0,VOL,-主動賣,0.2,0),COLORCC66FF;
STICKLINE(主動賣<= 0,0,-主動賣,3.2,0),COLOR990000;
STICKLINE(主動賣<= 0,0,-主動賣,2.7,0),COLORCC0000;
STICKLINE(主動賣<= 0,0,-主動賣,2.1,0),COLORFF4400;
STICKLINE(主動賣<= 0,0,-主動賣,1.5,0),COLORFF8800;
STICKLINE(主動賣<= 0,0,-主動賣,0.9,0),COLORFFCC00;
STICKLINE(主動賣<= 0,0,-主動賣,0.2,0),COLORCYAN;
持幣:IF(SAR(10,2,20)>= H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLOR00FF00,LINETHICK1;
DRAWICON(持幣> 0,持幣,35 );
持股:IF(SAR(10,2,20)<= L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK1;
DRAWICON(持股> 0,持股,34 );
個股資金線:=MA(C,1)/MA(REF(C,18),18)*100;
資金生命線:=MA(FORCAST(個股資金線,20),6);
生命線:個股資金線> 資金生命線,COLOR000000,STICK,LINETHICK1;
DRAWICON(生命線>0,生命線,34);
五日: MA(V,5);
十五日: MA(V,15);
三十五日: MA(V,35)COLORBLUE,LINETHICK2;

通達信資金流+成交量指標公式

 

相關文章

3d彩票软件excel