載入中...
在線檢測未來函數
載入中...

通達信雪無痕主圖指標公式

來源:Internet,編輯:股旁網,2019-11-18

N:=4;
K:=1;
DRAWGBK(C>0,RGB(0,150,150),RGB(0,00,100),0,' ',0);
VVAR1:=IF(K=1,(MA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,30)+MA(CLOSE,60))/4,DRAWNULL);
DRAWBAND(MA(C,3),RGB(120,120,00),VVAR1,RGB(30,100,200));
GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撐:=L+(C-GJ);
明日阻力2:=L+2*(GJ-L)+(C-L);
明日支撐2:=L+(C-GJ)-(GJ-L);
今日阻力:REF(明日阻力 , 1),NODRAW;
今日支撐:REF(明日支撐 , 1),NODRAW;
今日阻力2:REF(明日阻力2 , 1),NODRAW;
今日支撐2:REF(明日支撐2 , 1),NODRAW;
STICKLINE(ISLASTBAR,今日阻力,今日阻力2,20,0),COLOR555555;
{STICKLINE(ISLASTBAR,今日阻力2,今日阻力2,10,1),COLORAAAAAA;}
DRAWTEXT(ISLASTBAR,今日阻力,' 阻'),COLOR0000FF;
STICKLINE(ISLASTBAR,今日支撐,今日支撐2,20,0),COLOR555555;
{STICKLINE(ISLASTBAR,今日支撐2,今日支撐2,10,1),COLORAAAAAA;}
DRAWTEXT(ISLASTBAR,今日支撐,' 支'),COLOR00FF00;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
AAAX:=(3*C+H+L+O)/6;
龍:IF(K=0,(8*AAAX+7*REF(AAAX,1)+6*REF(AAAX,2)+5*REF(AAAX,3)
+4*REF(AAAX,4)+3*REF(AAAX,5)+2*REF(AAAX,6)+REF(AAAX,8))/36,DRAWNULL),COLOR00FF00;
鳳:=(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)
+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)
+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)
+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)
+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R4:=(REF(R3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R6:=(REF(R5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R8:=(REF(R7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RA:=(REF(R9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RC:=(REF(RB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
RE:=(REF(RD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RF:=(REF(RE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R11:=(REF(R10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R13:=(REF(R12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R15:=(REF(R14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R17:=(REF(R16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
VAR3:=IF(C<200 ,MA(COST(80),3),2500),NODRAW;
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR5:=EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),2330);
VAR6:=(VAR5 + ((VAR5 * 6) / 100));
短買春:=R19,NODRAW,COLOR00DD00;
秋離場:=R1A,NODRAW,COLOR2288DD;
持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
陰觀望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,NODRAW,COLOR999999;
急速超跌關注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORBBBBBB,NODRAW;
離場:=IF(紅持股,JRL,DRAWNULL);
明離場價:=離場,COLORFF99FF,NODRAW;
今離場價:=REF(離場,1)COLOR0000FF,NODRAW;
進:=IF(陰觀望,JRH,DRAWNULL);
明進場價:=進,COLOR33AACC,NODRAW;
今進場價:=REF(明進場價,1),COLOR00FF00,NODRAW;
Q1:=CONST(IF( 短買春,0,IF(秋離場,150,IF(紅持股,150,IF(急速超跌關注,150,100))))),NODRAW;
Q2:=CONST(IF( 短買春,100,IF(秋離場,100,IF(紅持股,0,IF( 急速超跌關注,150,100))))),NODRAW;
Q3:=CONST(IF( 短買春,0,IF(秋離場,20,IF(紅持股,70,IF( 急速超跌關注,150,100))))),NODRAW;
DRAWBAND(龍,RGB(Q1,Q2,Q3),鳳,DRAWNULL);
大雪:=MA((((HIGH + LOW) + CLOSE) / 3),8);
無痕:=MA((((HIGH + LOW) + CLOSE) / 3),21);
VAR111:=EMA(((OPEN + CLOSE) / 2),26);
VAR222:=IF(C<200 , MA(COST(30),3),2300),NODRAW;
天下有雪:=IF(C<200 ,MA(COST(50),3),2300);
嚴冬:=ISLASTBAR AND (VAR4 > 0.1),COLORFFFFFF,NODRAW;
早春:=ISLASTBAR AND (((((VAR4 < 天下有雪) AND (VAR4 > 無痕))
OR ((VAR4 < VAR5) AND (VAR4 > 無痕))) OR ((VAR4 > 無痕)
AND (VAR111 > 無痕)))),COLOR00FF00,NODRAW;
初夏:=ISLASTBAR AND ((((((VAR4 > 天下有雪) AND (VAR4 > VAR111))
AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) OR ((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))))),
COLOR0000FF,NODRAW;
深秋:=ISLASTBAR AND (((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 無痕))
AND (VAR111 > REF(VAR111,1)))),COLOR00FFFF,NODRAW;
SAAA:=(3*C+H+L+O)/6;
SVAR1:=(8*SAAA+7*REF(SAAA,1)+6*REF(SAAA,2)
+5*REF(SAAA,3)+4*REF(SAAA,4)+3*REF(SAAA,5)+2*REF(SAAA,6)+REF(SAAA,8))/36;
SVAR2:=(HHV(SVAR1,5)+HHV(SVAR1,10)+HHV(SVAR1,20))/3;
SVAR3:=(LLV(SVAR1,5)+LLV(SVAR1,10)+LLV(SVAR1,20))/3;
SVAR4:=(HHV(SVAR2,5)+HHV(SVAR2,10)+HHV(SVAR2,20))/3;
SVAR5:=(LLV(SVAR3,5)+LLV(SVAR3,10)+LLV(SVAR3,20))/3;
SVAR6:=(LLV(SVAR1,2)+LLV(SVAR1,4)+LLV(SVAR1,6))/3;
ZGD:=HHV(REF((C*2-REF(C,3)),3),30)*0.99,COLOR008888;
ZDD:=LLV(REF((C*2-REF(C,3)),3),30)*1.05,COLOR008888;
ZGD2:=IF(K=0,CONST(ZGD),DRAWNULL);
ZDD2:=IF(K=0,CONST(ZDD),DRAWNULL);
AA:=REF(H,N)=HHV(H,2*N+1); AA1:=REF(L,N)=LLV(L,2*N+1);
QY:=BACKSET(AA,N+1); QY1:=BACKSET(AA1,N+1);
CC:=FILTER(QY,N) AND H=HHV(H,N+1); CC1:=FILTER(QY1,N) AND L=LLV(L,N+1);
DDD:=BARSLAST(CC); DD1:=BARSLAST(CC1);
GDTS:=IF(CC,CURRBARSCOUNT,0); DDTS:=IF(CC1,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
GDCS1:=CONST(DINGBUTS); DDCS1:=CONST(DDTS1);
GDCS13:=CONST(REF(HIGH,GDCS1-1)); DDCS13:=CONST(REF(L,DDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1); DDTS2:=REF(DDTS1,DD1+1);
GDCS2:=CONST(DINGBUTS1); DDCS2:=CONST(DDTS2);
GDCS23:=CONST(REF(HIGH,DINGBUTS1-1)); DDCS23:=CONST(REF(L,DDTS2-1));
XG1:=BACKSET(ISLASTBAR,GDCS1); XD1:=BACKSET(ISLASTBAR,DDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1); XD2:=BACKSET(ISLASTBAR,DDTS2);
XDD:=IF(DDCS13<=DDCS23,XD1,XD2);
M:=INTPART(3*N/5);
AAA:=REF(H,M)=HHV(H,2*M+1);
QYY:=BACKSET(AAA,M+1);
CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0);
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);
GDCS11:=CONST(DINGBUTSS);
DINGBUTS11:=REF(DINGBUTSS,DDDD+1);
GDCS22:=CONST(DINGBUTS11);
AA11:=REF(L,M)=LLV(L,2*M+1);
QY11:=BACKSET(AA11,M+1);
CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
HH1:= REF(H,GDCS1-1),NODRAW;
HH2:= REF(H,GDCS2-1),NODRAW;
HH11:= REF(H,GDCS11-1),NODRAW;
HH22:= REF(H,GDCS22-1),NODRAW;
GHH:=MAX(MAX(REF(H,GDCS1-1),REF(H,GDCS2-1)),MAX(REF(H,GDCS11-1),REF(H,GDCS22-1))),NODRAW;
DLL:=MIN(MIN(REF(L,DDCS1-1),REF(L,DDCS2-1)),MIN(REF(L,DDCS11-1),REF(L,DDCS22-1))),NODRAW;
DX1:=(REF(H,GDCS1-1)-REF(H,GDCS2-1))/(GDCS2-GDCS1);
DDX1:=IF((REF(H,(GDCS1-1))+DX1*GDCS1)>ZGD2*1.02 OR (REF(H,(GDCS1-1))+DX1*GDCS1)<ZDD2*0.98,0,1);
DX2:=(REF(H,GDCS11-1)-REF(H,GDCS22-1))/(GDCS22-GDCS11);
DDDX1:=IF((REF(H,(GDCS11-1))+DX2*GDCS11)>ZGD2*1.02 OR (REF(H,(GDCS11-1))+DX2*DDCS11)<ZDD2*0.98,0,1);
LX1:=(REF(L,DDCS1-1)-REF(L,DDCS2-1))/(DDCS2-DDCS1);
LLX1:=IF((REF(L,(DDCS1-1))+LX1*DDCS1)<ZDD2*0.98 OR (REF(L,(GDCS1-1))+LX1*DDCS1)>ZGD2*1.02,0,1);
LX2:=(REF(L,DDCS11-1)-REF(L,DDCS22-1))/(DDCS22-DDCS11);
LLLX1:=IF((REF(L,(DDCS11-1))+LX2*DDCS11)<ZDD2*0.98 OR (REF(L,(DDCS11-1))+LX2*DDCS11)>ZGD2*1.02,0,1);
壓力:DRAWLINE(K=0 AND CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,DDX1),COLORYELLOW,LINETHICK1;
低支撐:DRAWLINE(K=0 AND CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,LLX1),COLORYELLOW,LINETHICK1;
DRAWLINE(K=0 AND CURRBARSCOUNT=GDCS22 ,H,CURRBARSCOUNT=GDCS11,H,DDDX1),COLORWHITE,LINETHICK1;
DRAWLINE(K=0 AND CURRBARSCOUNT=DDCS22 ,L,CURRBARSCOUNT=DDCS11,L,LLLX1),COLORWHITE,LINETHICK1;
CCA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DDA:=DMA(CLOSE,CCA);
第二回調線:(1-7/100)*DDA,POINTDOT,COLORWHITE;
等待:=IF(K=0 AND MA3>鳳,鳳,MA3);
IF(K=0 AND 龍> REF(龍,1),龍,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(K=0 AND 等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
IF(K=0 AND 鳳>REF(鳳,1),鳳,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(K=0 AND 鳳<REF(鳳,1),鳳,DRAWNULL),COLOR00FF00,LINETHICK1;
箱頂:IF(K=1 ,MA(REF(HHV(C,30),1),2),DRAWNULL)COLOR0000FF,LINETHICK2;
箱底:IF(K=1 ,MA(REF(LLV(C,30),1),2),DRAWNULL)COLOR00FF00,LINETHICK2;
KOH:=L>REF(H,1);
KOL:=H<REF(L,1);
HIF:=L>REF(H,BARSLAST(KOH)+1);
NHIF:=L<=REF(H,BARSLAST(KOH)+1);
LIF:=H<REF(L,BARSLAST(KOL)+1);
NLIF:=H>=REF(L,BARSLAST(KOL)+1);
下檔線:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下檔線,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
壓力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
壓力位:=IF(ISLASTBAR,壓力2,DRAWNULL),NODRAW;
底部位:=IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
STICKLINE(ISLASTBAR ,壓力位,壓力位,120,0),COLORFFFFFF;
STICKLINE(ISLASTBAR ,底部位,底部位,100,0),COLOR00FF00;
STICKLINE(ISLASTBAR AND (紅持股 OR REF(紅持股,1)=1),今離場價,今離場價,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (陰觀望 OR REF(陰觀望,1)=1),今進場價,今進場價,30,1),COLOR00FF00;
{賣出------------------------}
VAR55:=EMA(EMA(EMA(CLOSE,8),13),62);
VAR56:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR57:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VAR58:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),7,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),7,1)) * 100);
賣出1:=FILTER(CROSS(79,VAR58),4);
MA21:=REF(CLOSE,1);
ZX:=((SMA(MAX((CLOSE - MA21),0),6,1) / SMA(ABS((CLOSE - MA21)),6,1)) * 100);
賣出2:=CROSS(84,ZX),COLORFF00FF;
賣出3:=CROSS(90,RSI);
賣出:=賣出1 OR 賣出2 OR 賣出3;
DRAWICON(賣出,(HIGH * 1.002),15);
{買入------------------------}
QQ2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
QQ3:=SMA(QQ2, 9, 1);
QQ4:=SMA(QQ3, 3, 1);
趨勢:=3*QQ3-2*QQ4,COLORWHITE,LINETHICK3;
趨勢線:=EMA(QQ3, 3),COLORRED,LINETHICK3;
金叉:= CROSS(長趨勢,趨勢線);
AAAA1:=AMOUNT/V;
BBB1:=L<AAAA1*0.9;
CCC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DDD1:=L<MA(C,5)*0.921;
EEE1:=V<MA(V,5)*1.5;
老鼠倉:=BBB1 AND CCC1 AND DDD1 AND EEE1,,NODRAW;
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
VAR1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
VAR2:=( MA((CLOSE-VAR1)/VAR1,1));
VVAR3:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VVAR4:=SMA(VVAR3,4,1);
MMA:=EMA(VAR2,12)*0.7;
MMB:=EMA(VAR2,3);
快到底:=IF(LLV(MMB-MMA,12)>0,0,-20),LINETHICK2,COLORGREEN;
DIFF:=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
抄底:=IF(快到底<0 AND CROSS(MACD,0) AND VAR4<18,1,0);
AVAR2:=(2*CLOSE+HIGH+LOW)/4;
AVAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
AVAR4:=LLV(LOW,5);
AVAR5:=HHV(HIGH,4);
散戶:= EMA((AVAR2-AVAR4)/(AVAR5-AVAR4)*100,4)*AVAR3;
莊家:= EMA(0.667*REF(散戶,1)+0.333*散戶,2)*AVAR3;
AA05:=MA(C,5),COLOR0099CC;
五日乖離率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖離率:=(C-AA30)/AA30*100;
加倉:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1) AND 三拾日乖離率>REF(三拾日乖離率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MV3:=EMA(V,3);
MV3角度:=ATAN((MV3/REF(MV3,1)-1)*100)*180/3.1416;
MA3角度:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;
MV5:=EMA(V,5);
MA5:=EMA(C,5);
MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;
MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
MV10:=EMA(V,10);
MA10:=EMA(C,10);
MV10角度:=ATAN((MV10/REF(MV10,1)-1)*100)*180/3.1416;
MA10角度:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
強弱度:=(MV3角度+MA3角度+MV5角度+MA5角度+MV10角度+MA10角度)/6,COLORFFFFFF;
QBD:=CROSS(強弱度,50) AND COUNT(強弱度>50,7)<=3;
啟爆點:=IF(K=0 AND QBD AND COUNT(QBD,4)=1,50,0),COLOR00FFFF;
半月相對價位:=(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*10;
半月相對價位M:=SMA(半月相對價位,3,2);
半月相對價位MM:=SMA(半月相對價位M,10,6);
K13:=MA(半月相對價位MM,3);
福緣:=半月相對價位MM>=K13,COLORRED;
啟爆福緣:=啟爆點 AND 福緣;
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
AK:=EMA((DMP-DMM)*1,3)*100+50,COLORFFFFFF;
AD:=EMA((MA(DMP,3)-MA(DMM,3))*1,3)*100+50,COLORFFFFFF;
DRAWICON(CROSS(AK,AD) AND 啟爆點 AND 福緣,L*0.99 ,9);
DRAWICON(加倉,L*0.99,23);
DRAWICON(老鼠倉 OR 金叉,(LOW - (LOW * 0.01)),1);
DRAWTEXT(秋離場,HHV(H,3),'→→→→'),COLORFF99FF;
DRAWTEXT(短買春,LLV(L,3),'←←←←'),COLOR00FF00;
{嚴冬:}STICKLINE((VAR4 > 0.1),HIGH,LOW,0,0),COLORFFFFFF;
{早春:}STICKLINE(((((VAR4 < 天下有雪) AND (VAR4 > 無痕))
OR ((VAR4 < VAR5) AND (VAR4 > 無痕))) OR ((VAR4 > 無痕)
AND (VAR111 > 無痕))),HIGH,LOW,0,0),COLOR00FF00;
{初夏:}STICKLINE((((((VAR4 > 天下有雪) AND (VAR4 > VAR111))
AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) OR ((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1)))),
HIGH,LOW,0,0),COLOR0000FF;
{深秋:}STICKLINE(((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 無痕))
AND (VAR111 > REF(VAR111,1))),HIGH,LOW,0,0),COLOR00FFFF;
STICKLINE(((VAR4 > 0.1) AND (CLOSE < OPEN)),OPEN,CLOSE,2.8,0),COLORCCCCCC;
STICKLINE(((VAR4 > 0.1) AND (CLOSE >= OPEN)),OPEN,CLOSE,2.8,1),COLORCCCCCC;
STICKLINE(((VAR4 > 0.1) AND (CLOSE >= OPEN)),OPEN,OPEN+(CLOSE-OPEN)/3,2.8,0),COLORFFFFFF;
STICKLINE((((((VAR4 < 天下有雪) AND (VAR4 > 無痕)) AND (CLOSE < OPEN))
OR (((VAR4 < VAR5) AND (VAR4 > 無痕)) AND (CLOSE < OPEN)))
OR (((VAR4 > 無痕) AND (VAR111 > 無痕)) AND (CLOSE < OPEN))),
OPEN,CLOSE,2.8,0),COLOR00FF00;
STICKLINE((((((VAR4 < 天下有雪) AND (VAR4 > 無痕)) AND (CLOSE > OPEN))
OR (((VAR4 < VAR5) AND (VAR4 > 無痕)) AND (CLOSE > OPEN)))
OR (((VAR4 > 無痕) AND (VAR111 > 無痕)) AND (CLOSE >= OPEN)))
,OPEN,CLOSE,2.8,1),COLOR00FF00;
STICKLINE(((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5))
AND (VAR222 > REF(VAR222,1))) AND (CLOSE < OPEN)) OR (((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,2)))
AND (CLOSE < OPEN))),OPEN,CLOSE,2.8,0),COLOR0000FF;
STICKLINE(((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5))
AND (VAR222 > REF(VAR222,1))) AND (CLOSE > OPEN)) OR (((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1)))
AND (CLOSE >= OPEN))),OPEN,CLOSE,2.8,1),COLOR0000FF;
STICKLINE((((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 無痕))
AND (VAR111 > REF(VAR111,1))) AND (CLOSE < OPEN)),OPEN,CLOSE,2.8,0)
,COLOR00FFFF;
STICKLINE((((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 無痕))
AND (VAR111 > REF(VAR111,1))) AND (CLOSE >= OPEN)),OPEN,CLOSE,2.8,1)
,COLOR00FFFF;

通達信雪無痕主圖指標公式

 

通達信雪無痕主圖指標公式的選股公式如下:

http://www.vwdidt.tw/201911/48833.html

http://www.vwdidt.tw/201911/48834.html

http://www.vwdidt.tw/201911/48835.html

http://www.vwdidt.tw/201911/48836.html

http://www.vwdidt.tw/201911/48837.html

相關文章

3d彩票软件excel